PHP

Niet iedere website is geschikt voor iedere versie van PHP. Op onze webhosting servers zijn daarom altijd twee versies geïnstalleerd. Ieder webhosting pakket kan gebruik maken van PHP versie 5.6 en PHP versie 7.1. Meer technische informatie over de verschillende PHP versies is terug te vinden op php.net.

Welke versie heb ik nodig?

Deze vraag kan het beste beantwoord worden door de ontwikkelaar van de website. Voor systemen als WordPress, Joomla en Magento staan de systeemvereisten op de volgende websites:

Hoe selecteer ik een andere PHP versie voor mijn website?

  1. Login via www.uwdomeinnaam.nl/config.
  2. Klik onder Your Account op Domain Setup.
  3. Klik op uw domeinnaam.
  4. Onderaan de pagina staat de PHP Version Selector.
    • First PHP: dit is PHP versie die gebruikt wordt voor alle bestanden eindigend op .php. Deze wordt standaard gebruikt.
    • Second PHP: het is ook mogelijk om bestanden die op .php56 of .php71 eindigen een andere PHP versie mee te geven.
  5. Klik op Save om de wijzigingen op te slaan.

Hoe controleer ik mijn PHP versie?

Je kunt daarvoor gebruik maken van phpinfo(). Upload een bestand met de naam php.php en plaats hier in de volgende code:

<?php
phpinfo();
?>

Wanneer je in de browser naar www.uwdomeinnaam.nl/php.php gaat krijg je alle informatie over de huidige PHP versie te zien.